Tuesday, March 20, 2007

Add a package in Solaris 9

Some things to try

1> Remove a package...
# pkgrm SUNWbzip

2> Check to see if a package is installed...
# pkginfo SUNWbzip

or

# pkginfo -l SUNWbzip

3> If a package is installed, see where it installed to...
# pkgchk -v SUNWbzip

4> Add a package from the Solaris 1 of 2 CD's...
# cd /cdrom/sol_9_905_sparc/s0/Solaris_9/Product
# pkgadd -d . SUNWbzip

5> Run through a few things...
# pkgrm SUNWbzip
# pkginfo -l SUNWbzip
# pkgchk -v SUNWbzip

# cd /cdrom/.../Products
# ls
# pkgadd -d . -s spool SUNWbzip (add this package as a spooled package only)
# ls -l /var/spool/pkg

# cd /
# pkgadd SUNWbzip (the package will add if it is located in /var/spool/pkg)
# pkginfo SUNWbzip (to see if it actually got installed)

No comments: